Visual Studio 2013?

Mar 17, 2015 at 9:51 PM
Is this compatible, as I too am having a lot of difficulty getting the new items to show up in the toolbox.

I'm running SQL 2014, Visual Studio 2013 Data Tools, Windows 8, and my Visual Studio is not on my OS drive, the installation window shows installation to this path: w:\Program Files\SQLServer2012\SharedFeaturex86\120\DTS\PipelineComponents and have tried uninstalling and installing by hand using gacutil commands.

Thanks.
Coordinator
Mar 17, 2015 at 10:57 PM
Edited Mar 17, 2015 at 11:02 PM
Hi Lara,

sure, this component is fully compatible with VS 2013. I used VS2013 ultimate to test it and it is perfectly working. Only make sure you're on the "Data Flow" view and not in the Control Flow. This component will only apper when inside the dataflow environment. If still not appearing, try to right click on the SSIS toolbox and then select "Refresh Toolbox".

Image

Some other troubleshooting tips to perform:
1) Open VS 2013 and create a SSIS Project
2) From the toolbar, select "Tools" -> "Choose Toolbox Items". A window will appear
3) Select ".NET Framework Components" from the tabs, then select "Browse" and point to the com.webkingsoft.jsonsource_120.dll you downloaded.

See which kind of error you get and post it here. This mechanism won't work of course, since it's not supposed to. But, if there's any explicit error with dependencies, the error message should tell you what's wrong. If everything is working, something like the following message should appear:
"There are no components in ..... that can be placed on the toolbox". If that appears, the error is elsewhere.

Before looking for other possible sources of error, please do that and let me know what happens.

Alberto.
Mar 17, 2015 at 11:44 PM
Thanks for replying Alberto. I was able to finally get it registered. I think the problem is I have 4 versions of SQL and Visual Studio installed. So it was just a matter of finding each directory where PipelineComponents held the .dll's then I did this:
  • Copied the three necessary pieces to use Gacutil (gacutil.exe, gacutil.exe.config and gacutlrc.dll) to those PipelineComponents folders.
  • Uninstalled the dll's by
    gacutil /u com.webkingsoft.JSONSource_120 
    gacutil /u Newtonsoft.Json
  • Received the confirmation they were uninstalled
  • Installed them dll's by
    gacutil /i com.webkingsoft.JSONSource_120.dll 
    gacutil /i Newtonsoft.Json.dll
  • Restarted Visual Studio 2013, went to data flow and looked under Common items in the toolbox.
The correct path which finally added the items to the toolbox was: Program Files\SQLServer2012\SharedFeaturex86\120\DTS\PipelineComponents

I was unable to add it to my toolbox items by browsing, but perhaps i was attempting to load in the incorrect dll's from the incorrect folders, like I said, probably because I have 4 installations.

Again, I don't think it's your installation software - but my crazy installation setup paths and multiple copies of Bids and SSDT. I had a co-worker attempt to install and he was fine, but he only had one version of SQL installed and one version of Visual Studio (2013 SSDT).

Thanks again for writing back so quickly!
Coordinator
Mar 18, 2015 at 6:13 AM
Edited Mar 1, 2016 at 10:24 PM
I'm glad you've fixed it. I'll write down a note for a future release of the installation software to check multiple installation paths, simulating your environment. Ty for testing it! Alberto.
Marked as answer by webking on 3/18/2015 at 3:09 AM