This project has moved. For the latest updates, please go here.

Can't configure Json Source

Apr 9, 2016 at 11:48 AM
Hi

Just downloaded the latest version and when i try to edit the Json Source Component i just get on error message saying that "This component has no input columns.Do you want to continue editing the avaliable properites of this component?"
If i click yes i just get the Advanced Editor dialog.

In my other project that i have on my server i did have to have input columns?
It's not the same version though.
Have something changed?

/Ronny
Coordinator
Apr 9, 2016 at 12:18 PM
Hi,

yes, the new version has some improvements and supports input columns. However it works the same if no input column is provided. Upgrading the component is not yet supported! When you install a new version of the software (I suppose you've installed latest beta 1.1.000) the component does not know how to upgrade previous metadata.

So, you have to do the following:
  1. Save a copy of the current project somewhere else, for backup.
  2. Edit the project and remove all the JsonSource component from it.
  3. Close VS
  4. Open again VS and open the project where no JSOSource component is listed.
  5. Re-insert and re-configure JSONSource components.
At this point you should be able to use the component again.

I am sorry about this, however supporting automatic metadata upgrade is painful and requires a lot of time. I'll add this point as future work request, so future version will somehow try to fix this.

Let me know if you fix this problem,

Alberto.
Apr 9, 2016 at 2:15 PM
Hi

The thing is that i installed the 1.1.000 version over the one i hade.
The i started VS and opened a new project.
So i didn't have any old meta data...

I also tried to do what you said now, since i hade installed the version i hade om the server, but still same problem.

/Ronny
Coordinator
Apr 9, 2016 at 6:10 PM
I can't reproduce the issue on my server, so I have to ask you this.
Have you tried closing vs, open ot again and creating a new project? Does it work with new projects?
Coordinator
Apr 9, 2016 at 7:26 PM
Perhaps there was a problem with the uninstallation. So, please follow the following steps:
1) Using GAC Manager as administrator, search for dlls containing "com.webkingsoft" and "newtonsoft". Remove all of them.
2) Make sure to remove the same dlls from the following locations (if present)
C:\Program Files (x86)\Microsoft SQL Server\120\DTS\PipelineComponents
C:\Program Files\Microsoft SQL Server\120\DTS\PipelineComponents
C:\Program Files (x86)\Microsoft SQL Server\110\DTS\PipelineComponents
C:\Program Files\Microsoft SQL Server\110\DTS\PipelineComponents

3) Install them again, using the installer or the manual installation of the DLL pack
4) Try again to create a new project and use this component.


Let me know the result,

Alberto.
Apr 9, 2016 at 8:44 PM
Okay, so ths installation DOES not install in the SQL 120 64 bit folder (C:\Program Files\Microsoft SQL Server\120\DTS\PipelineComponents) but does in the rest.
I have tried to put them there and resiter them.
but it should not matter since the VS is running in 32 bit then they do exist in C:\Program Files (x86)\Microsoft SQL Server\120\DTS\PipelineComponents after the install.

I uninstalled and checked that they where removed and they was removed.
I installed and then did the copy to the C:\Program Files\Microsoft SQL Server\120\DTS\PipelineComponents and resigered them.

I'm not sure what more i can do.
The version before this works in i install that one. I have no problem with that version at all...

I have Windows 10, could that be a problem?
I have SQL 2012 Standard and SQL 2014 Express Adv installed.

It's strange...
Maybe i just have to wait to next version and see if that one works better, or do you have anything more i can test?

So i can use the earlier version for now because that works, but it would have been nice to see the new features u put in.
I might be able to install on the server later this week and see if i have the problem there or not, but not right now since i'm running major tests there right now.

/Ronny
Apr 15, 2016 at 7:47 PM
Edited Apr 15, 2016 at 7:48 PM
Hi,

I just installed Version 1.1.000, but there is no option to configure json source. I am using VS 2013 32-bit on windows 7 - this is first time that I tried using this component... just want to read a json url and write it to sql server.

Josie.
Coordinator
Apr 16, 2016 at 5:37 PM
Hi.

I don't understand what are you saying. What do you mean by "there is no option to configure JSON Source"?
Could you post a screenshot and/or elaborate more?
Apr 19, 2016 at 9:44 PM
Hi, I have exactly the same problem. I just installed the component but it keeps asking me for input columns !!
I just want to parse JSON file from the disk.
I can't find anywhere in the advanced editor a place where to put the path of the file I want to parse.

Alex
Coordinator
Apr 19, 2016 at 11:28 PM
Hi,
I cannot reproduce the problem on my machine. Can you give me more info about the problem?
  1. To edit the component, simply double-click on it.
  2. If the Advanced editor appears instead of the custom one, please put the following value into the CONFIGURATION_MODE_OBJECT custom field:
{"DataSource":{"SourceUri":null,"FromVariable":false,"VariableName":null,"HttpParameters":null,"CookieVariable":null,"WebMethod":null},"DataMapping":{"_ioMap":null,"RootType":0,"JsonRootPath":null,"InputColumnsToCopy":null},"AdvancedSettings":{"CustomLocalTempDir":null}}
  1. Save and try again.
If the problem it's solved, it usually means there was a corrupted project/installation. This happens usually when trying to updating the component with old metadata.

Does this fix the problem?

Alberto.
Apr 20, 2016 at 1:57 PM
Edited Apr 27, 2016 at 5:27 PM
Hi webking,

I am facing the same problem, I believe this has something to do with VS2013.

The solutions presented above did not work to me.

Image

Image
Apr 27, 2016 at 3:30 PM
Edited Apr 27, 2016 at 3:31 PM
I'm running into the same issue.

Windows 7
SSDT BI for VS 2013
JSON file on disk

Install component and get the same message as screenshot in previous post. This is a new project after installation of component. The custom field CONFIGURATION_MODE_OBJECT is not found for the source component.
Coordinator
Apr 27, 2016 at 3:59 PM
Hi All,

I will try to reproduce the problem tonight. Hopefully this will be fixed within this week. I apologize for the inconvenience and I'll keep you informed.
I am moving this thread to the WorkItems-Issues.
Coordinator
Apr 27, 2016 at 4:00 PM
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.
Coordinator
Apr 28, 2016 at 8:28 PM
Bug has been fixed, please download again the installer and reinstall JsonSource. Start a new project in order to be sure that everything is ok.

Let me know if the problem persists.

Regards,

Alberto.
Marked as answer by webking on 5/5/2016 at 12:19 AM